Tuesday, July 22, 2008

Eclipse 3.4, Trac 0.11 and Mylyn

I have been working on setting up the configuration management environment at work place. I chose BUILDIX 2.1 from Thoughworks as the tool of our choice since it comes free of cost. The buildix distribution comes with Trac 0.10, CruiseControl , Subversion and Mingle integration bundled with Ubuntu Linux VMWARE image.

However the issue tracker Trac 0.10 that comes with Buildix 2.1 does not support the advanced ticket work flows. So I decided to upgrade it to 0.11. The upgrade went very well. Meantime, I upgraded our eclipse environment to 3.4 as the IDE of our choice. The Mylyn task based UI plugin of eclipse works so great and the eclipse 3.4 version of Mylyn comes with JIRA, BugZilla and Trac connectors. However, by default Mylyn only supports Trac 0.9.2 Trac 0.10.x versions.

So basically we lost connectivity from Eclipse to our issue tracker with the upgrade. Then this article about Trac 0.11 and Mylyn becomes handy that provide simple instructions to make Eclipse 3.4 Mylyn talk to Trac 0.11.

I had to install TracXMLRPC 1.0.0 plugin from the Trac SVN repository and enable the plugin via Trac web admin module. I then re-started the apache web server as per the instructions given at the article I mentioned above The eclipse 3.4 Mylyn can now talk to Trac 0.11 issue tracker and I can see all the tickets.

Hope this blog helps other users who encountered issues in integrating Eclipse 3.4, Mylyn and Trac 0.11.


3 comments:

Tarakanath said...

Thanks for this blog Mike. It was helpful.

Anonymous said...

girls [url=http://pornushi.ru/english-version/young-girls-pussys/doc_810.html]videos de gays[/url]

sports handicapping software said...

very useful information